Database Help Framework Diagrams

Database Help Framework Diagrams

DiagramDescription
Diagram D01Database Help Framework Data Tables
Diagram D02Database Help Framework Configuration Tables

Diagram D01. Database Help Framework Data Tables

Database Help Framework Data Tables

Database Help Framework allows editing database documentation in Microsoft Excel and generating the documentation in HTML format.

The doc.help table contains help topics.
The doc.help_sections table contains help sections like objects, schemas, roles, diagrams, pages, and properties.
The doc.history table contains database history topics.
The doc.history_sections table contains history sections like announcements, new features, improvements, and bug fixes.

The Excel application uses editable views to edit the table data.

Add users who can write the documentation to the doc_writers role.
Add users who can read the documentation to the doc_readers role.

Diagram D02. Database Help Framework Configuration Tables

Database Help Framework Configuration Tables

Database Help Framework includes complete copies of SaveToDB Framework tables.

This allows using Database Help Framework as is, without additional requirements.

The doc.objects table contains the configuration how to save data changes back to a database.
It specifies the target tables and stored procedures for INSERT, UPDATE, and DELETE operations.

The doc.handlers table contains the handler configuration.
It configures action menu items and validation lists for framework objects.

The doc.translations table contains translations of database objects, columns, parameters, and generated help headers.

The doc.formats table contains Excel table formats for framework objects.
The SaveToDB add-in applies these formats in the first connection to database objects.
Users can save and reload table formats using SaveToDB Table Format Wizard or Save Table Format and Load Table Format menu items.

The doc.workbooks table contains a configuration to generate a workbook to edit the database help.
Use the Application Workbooks wizard to generate it.